Mac : MacPorts selfupdate failed on OSX Mavericks

By | October 24, 2013

Upgraded to Mac OSX Mavericks lately? Well, you’ll need to update MacPorts once you’re done to keep it working.

To update MacPorts, just do the following command in Terminal :

The terminal will keep working running a bunch of scripts by itself, then you end up with the following output error :

This mean you need to update Xcode and install the “command line developer tools”… just do :

You will be prompt the following message :

xcode-select: note: install requires for command line developer tools. Would you like to install the tools now?

Simply click “Install” and you’re through!