Mac : OpenVPN JSONDialog: Error running jsondialog

By | March 1, 2016

Have you encountered the following error trying to connect to OpenVPN server?

JSONDialog: Error running jsondialog, status=(5, [], [‘task_for_pid(): 0x5’]), stdout=[],

I have observed the following error message under the following circumstances :

Operating system : Mac OSX El Capitan 10.11
OpenVPN client : v2.0.18.202 or older version

The problem occur because of the System Integrity Protection (SIP) feature of the new OSX systems which is also referred as “rootless”. This prevent certain system files, folder and process to be modified, even by root for security purpose.

To fix this issue, please upgrade your OpenVPN client to version 2.0.18.203 (or higher) or disable the System Integrity Protection (not recommended).




Be Sociable, Share!